My replacement Arris Gateway DG2460A works wirh my Suddenlink Provider, but not with my ROKU. My older DG2460A worked with both. I suspect that maybe my Arris DG2460A has had it’s Password changed.

This topic has been closed for comments

10 replies

Userlevel 1

Is there any special characters or spaces in the ssid or password? 

I’ve seen some of the roku’s struggle with that. 


NO it’s all alpha-numeric, all caps, no spaces. I also did a factory reset on the Gateway and that didn’t help. 

Thanks for your reply!

Userlevel 1

are you connecting it to the 2.4ghz or the 5ghz? 

Try changing the default 2.4ghz and 5ghz channels 


I forgot my Surfboard password and have been flailing about. My DG260 Gateway doesn’t show up on my ROKU “network scan”. I’ve tried entering the 5G version as a “private network” but that doesn’t fly...

The network that shows up on my laptop is “” if that helps. That network doesn’t show up on the ROKU search.

My ROKU is a 3930X

Userlevel 1

Are you able to log into the gateway? Did you get that sorted so you can check the ssid info?

OK, I’d best be upfront. I’m 82 years old and some of this stuff is unfamiliar.. By “log into to the Gateway” do you mean from the computer?  No I’ didn’t log on, and I don’t know what SSID is.

I’ll look up SSID and try logging on to the gateway. Talk to you later..

Thanks, John

Userlevel 1

The gateway is the modem/router combo device. 

First we need to get you logged into it so you can change settings. 

You can find the manual here:



OK, I’ve downloaded the user manual. Now what?

Did you see my note that the Gateway works on my laptop, but doesn’t show up on my ROKU search?

I think I’ve found my problem. My Modem is set to 5G and my ROKU doesn’t do 5G. Guess I’ll get a new ROKU.

Thank’s for all your help!