mAX Pro W31 trying to add 2nd satellite

  • 4 October 2023
  • 4 replies


When trying to add a mAX Pro W31 satellite I get the the registration part and the app kick me out and closes.  I check the app for updates but the app is up to date.  Any body know why I can’t add the satellite or why it kicks me out?


Best answer by SURFboard Moderator 7 October 2023, 21:53

View original

4 replies

Userlevel 5
Badge +41

Hello tkulik

                    In this case please confirm few details to help you on this case further

                    Is your satellite placed next to the main router while setup?

                    Did you performed hard reset on the satellite and tried to setup? If Yes

                    May i know how long you reset the satellite? 

                    After resetting may i know light status on the satellite

                   You can try resetting satellite for 15 secs then try setting up it with the application

                   Please help me with the LED light status on the satellite after resetting.




I did try to connect it up next to the router, it did not work.    I did perform a hard reset on the satellite a couple of times per the instructions on the website and tried to connect it but as always when it got to the register portion it kicked me out of the app.  I pushed the reset button at the bottom from 20 seconds to a minute at different times but none worked.  If I am correct the light on the satellite was yellow/orange.  The app connected with the satellite, it connected with the router and WiFi but at the end of set up when it was time to register it would kick me out of the app.  My son says I should delete the router and try to add it, then add the satellite but I am reluctant to do that because I may have the same problem with it.


I have done the hard reset again, have connected with WiFi and an Ethernet cable and when I get to Register your device it kicks me out.  The color of my ring is below,


Userlevel 5
Badge +41

Since you tried all the steps to connect the satellite, I suggest you swap the routers ( satellite as the main router and main router as a satellite).

After swapping, uninstall the application reinstall it again, and set it up.