Not off to a good start with ghe G36 Modem

  • 30 July 2022
  • 2 replies

I attempted to register the SN of my new G36 today online, I made several attempts and got a message that the SN from the box and the device don’t match the product.  I called their help line and the man said that he will register the device.  I have had this modem for about 2 weeks and the wifi in the house is fine but I also have 3 ethernet connections in different rooms that have worked flawlessly with my TIVOs since I moved into this house almost 9 years ago.  Now, the ethernet connections are not working.  The modem did not come with setup instructions and I’m not sure which I should have plugged into the 2.5GB port on the modem, should I have the wifi or the ethernet that come from the wall?  I would love to get my ethernet ports working again.  This has been a horrible transition to the new modem.  Arris says the G36 is the top of the line, my opinion, it’s a pain in the neck!

2 replies

Userlevel 1

ARRIS keeps all the user guides online on the customer support site.  You can find the G36 user guide here.


As to the Ethernet ports, you should be able to plug any Ethernet products directly into any of the ports, including 2.5Gb port.  To quickly diagnose the issue, you could bring a laptop that has Ethernet port and connect it directly to the ports on G36 to see if it works.  If it does, there must be something else in your network that messes things up.  Do you have a switch or another router?

Thank you so much for your response.  It’s still not working, I continue trying different things.