add satellite function not working W130/W30

  • 16 August 2023
  • 3 replies


When trying to add my w31 satellite in the app, once I get to the first screen the next button does nothing. I have tried multiple devices with the same result. I have even reset both routers and reconnected the main device successfully. It appears that the add satellite function is just not working. Any ideas of what to try or is this a bugged app issue?


Best answer by SURFboard Moderator 17 August 2023, 21:14

View original

This topic has been closed for comments

3 replies

Userlevel 5
Badge +41

Appreciate your effort. If the satellite is not connecting with main router, make sure that satellite is next to main router.

and also you can try with power cycle and reset the satellite.

After power cycle and reset, relaunch the Surfboard central application and follow the steps in the below given link:



The issue I am having is with the app itself, not the satellite unit. If and when I can login to the app, the add satellite function is not working at all.

Userlevel 5
Badge +41

Please try uninstalling and re installing app and start setup again and also try restarting your modem and your mesh system then start setup.