Question

SBG8300 no longer works with xfinity

  • 22 October 2023
  • 8 replies
  • 423 views

Badge

One day my SBG8300 lost internet connection from Xfinity, Xfinity told me it was the modem, so I bought a new SBG8300. It also had no internet connection. Xfinity then told me they updated the area network and the SBG8300 was no longer compatible with Xfinity. I needed an update for the SBG8300.

I looked and there is no software update for SBG8300. Is there a solution for this?


This topic has been closed for comments

8 replies

Userlevel 6
Badge +40

If 2x modems have the same issue, it isn’t the modem. Its something for xfinity. Do hardwired devices work?

Badge

No, wired ethernet does not work either.

Userlevel 6
Badge +40

I’d call and talk to a new rep and explain you’ve replaced the modem and both had the same issue. 

there isn’t an update for it as its part of the provisioning from xfinity (and the rep’s are aware of this. its usually a tactic to get people off the phone)

Badge +1

SBG8300 still appears as an approved device on xFinity Web site.

Maybe the rep explained it poorly -- xFinity may need to push an update to your 8300?

Userlevel 6
Badge +40

@Polonia The SBG8300 is a modem router combo device. The firmware for it is part of the provisioning from xfinity. 

Anytime a tech tells you that, they’re trying to get you off the phone

Badge

I ended up renting xfinity’s Modem, when setting the xfinity modem up it didn’t work either, she told me we could solve the problem by giving it a custom name. Once it had a custom name it worked. It made me wonder if they could have given the SBG8300 a custom name to make it work.

Userlevel 6
Badge +40

Sounds more like an SSID issues than a modem/router issue

Userlevel 5
Badge +41

We understand that both of your sbg8300 modem didn’t work in order to connect internet , Could you update the light status of the modem ? If the LED light status of the modem is Solid green on the “Online” and :Wi-Fi” then lets try customizing the Wi-Fi Names and give it a try. 

To change the Wi-Fi names Kindly check the link below : 

http://arris.force.com/consumers/articles/General_FAQs/SBG8300-Changing-the-Wi-Fi-Name-and-Password

If still the modem is unable to connect internet then we need to check the “WAN IP” ?