Update: Speed Test Service

  • 28 December 2022
  • 7 replies

Userlevel 2
Badge +3

Hey SURFboard Community, 

The speed test service on the SURFboard Central app is not supported at this time, but we are working to resolve this and offer the service again as soon as possible. 

In the meantime, you get your ISP speed test site from the list below. Alternatively, you can also download the fing mobile app or desktop app to run speed tests, visit fing.com to learn more about these apps.


Internet Service Provider Speed Test URL
AT&T http://www.att.com/speedtest/
Atlantic Broadband http://speedtest.atlanticbb.net/
Cable One http://myspeedtest.cableone.net/
Century Link http://speedtest.centurylink.net/
Charter http://speedtest.charter.com/
Xfinity (Comcast) https://speedtest.xfinity.com/
Cox https://www.cox.com/residential/support/internet/speedtest.html
Spectrum https://www.spectrum.com/internet/speed-test.html


I’m curious what’s everyone’s “go to” speed test site/app, let us know in the comments! 

7 replies

Userlevel 6
Badge +40

dslreports is a good one but only for speeds under gigabit. 

Otherwise the ISP specific ones as they tend to be more accurate over gigabit. 

When I first installed my Arris G34 modem the surfboard central app recognized the modem and showed it as a G34. The speed test part of the app worked on the router (W31) WiFi side. And it worked between the G34 and Spectrum cable service. So I got speed test results on both sides.

After about the first week after initial install the G34

started showing up in the app like a generic modem of unknown brand. The speed test doesn’t work on the internet side or the WiFi side anymore.

i just use my laptop plugged into the modem and use either DSLreports or Spectrum.

I think the surfboard central is a pretty poorly developed app and does a lousy job of setting up your devices.

Speed Test: I use Mediacom - https://mediacomcable.com/speedtest/

Question:  Why would an update to the surfboard app be released that causes a function, such as the WiFi speed test?\, to cease working?  I have been in the programming business for many years, and I have never heard of a company that would not debug “everything” prior to release.  Hopefully the fix for this is a high priority.

Userlevel 6
Badge +40

@Foxe1977 it might not be an app issue causing the problem but a price difference from speedtest. The speedtest site is free for home users but business has a price to pay to incorporate it into their apps and maybe its in negotiation. Or something else changed on the backend. Tough to know with limited info but it might not be a programing issue. 


Honestly, I would never recommend using an ISPs speed test.  There are too many way the ISP can fudge the test.  Always use a real world speed test like www.speedtest.net

I just upgraded my connection to a 2Gig service, and the only way I can test is through my gateway using the app. Any idea when this functionality will be restored? 

Please turn the feature back on. Maybe this seemed like a small thing to Arris, but given the lack of standard features to begin with, coupled with a poor designed app that runs advertisements… it’s like you want customers to never return. The management through the Surfboard App is already lacking major features. Inability to do anything with an Arris modem in the app (other than see a pretty picture of it) is awful. Have to login to webgui to do anything and even then, major features are missing. For those of us that bought into the premium products Arris offers, this is a huge let down. I kept telling myself Arris would upgrade things… not a chance. I like many others will soon be upgrading to WIFI7… at this time I cannot imagine I’ll stick with Arris nor recommend to others. While I’m at. I have three of the W31s. The system does not properly handoff between nodes, and the feature that pushes devices to 5g straight up does not work. Also the ability to change names of devices through app is completely broken. Type all you want, it does not save it.