Question

G34 Loss of connection to Xfinity for all MAC filtered devices

  • 21 January 2024
  • 6 replies
  • 59 views

Badge +1

I randomly lose access to Xfinity for all MAC filtered devices on both frequencies. Working with Xfinity via their app and chat is truly frustrating. A power off/ reboot does not resolve the issue of the gateway connecting.  I end up having to connect my PC to the G34 and set both 2.4 and 5.0 to “Allow All” and save both configurations which negates the use of the manufacturer’s MAC address, All devices will then connect to Xfinity internet. I then change both 2.4 and 5.0 to “Allow” and my devices are then able to connect once again to the internet.

 

This lose of connection appears to be random as to when it will occur. The fix always appears to be going to “Allow All’ and then back to “Allow” for MAC filtering.

 

Anyone have any ideas as to why this is occurring, and why making the change back and forth for filtering resolves the issue?


6 replies

Userlevel 5
Badge +40

In this case could you please help us with few more details that how many devices are in MAC filtering setup?

Please try remove the devices on MAC filtering then restart modem for a minute then add the devices again in MAC filtering then monitor the connection.

Badge +1

15 devices on 2.4, and 9 devices on 5.0. It doesn’t matter the number of devices assigned to each frequency. When, what I expect is a gateway reset, being issued randomly during any unexpected time, all MAC filtered devices are then not able to connect to the internet. The router shows the devices connected with no internet, so the gateway recognizes the devices. When I then take all devices out of “ALLOW” and set them to “ALLOW ALL” the internet will be connected to by all devices. I then can take all devices and change filtering back to “ALLOW” and the devices will then be able to again log into the internet. 

 

I am trying to understand why any reset of the gateway will then prevent MAC configured devices to not have access to the internet. 

Userlevel 5
Badge +40

Could you perform factory reset one more time and check whether the MAC filtering devices are still configured.

http://arris.force.com/consumers/articles/General_FAQs/G34-G36-Factory-Reset

Badge +1

When you do a factory reset all of your MAC filtered devices are gone, so the answer to your question is NO, they are not still configured as they no longer exist. You have to go back and redo the filtering of all devices. BEEN THERE, DONE THAT more than once.

Userlevel 5
Badge +40

Could you let us know the Firmware version for the Wi-Fi cable modem G34.

Badge +1

Software Image Name: AR01.04.028.01.01_040121_724.NCS.20.X2

Firmware Version: AR01.04.028.01.01.NCS

Reply