S33v2 with Xfinity - 5Mbps upload? slow speed issue

  • 18 November 2023
  • 4 replies

Badge +1

I just replaced my Xfinity modem with an Arris S33(v2). While I’m getting about 720Mbps down I only get 5Mbps up.  I’m paying for 1000/200 service.

So far it’s taken Comcast 3 tries to get the modem provisioned and they seem to be stumped as to what’s going on.

The device log (which BTW isn’t sorted by date/time) contains the following after a restart (I added line breaks for readability):

17/11/2023 14:59:11	3	CMSTATUS:US_Diplexer_Mode_Change:TLV-84.1, 5-42MHz.
17/11/2023 14:59:17 6 DS profile assignment change. DS Chan ID: 32;
Previous Profile: ;
New Profile: 1 2 3.;
17/11/2023 14:59:26 3 UCD invalid or channel unusable;

Can anyone tell if the third message is meaningful in this context and what Comcast needs to do?

All the download channel signal levels seem to be good, with power at 0 or 1 dBmV and SNR 44dB

There are 4 upload channels bonded, with SC-QAM and power 46 dBmV.

Screenshot of the Connection page:



Best answer by jhg 21 November 2023, 19:28

View original

4 replies

Userlevel 4
Badge +39

In this case since you have done trying all possible trouble shooting I would suggest you to try checking and monitor connection for 24hrs using test modem from your internet service provider and if the test modem works fine you can reach out to support for further assistance if the modem is in warranty.

Badge +1

After going back and forth with Comcast I double-checked the speed on the Xfinity modem….

Using Comcast’s modem I get 900 down/240 up.

WIth the Arris S33v2 I get 700 down/5 up.

I had a tech come out to check signal levels and everything checks out.

The only possible conclusion is that the modem does not work with Comcast, even though they recommend this modem.  I guess I’ll have to return it.  Is it possible this is a deliberate ploy by Comcast to preserve their pure profit $15/month modem rental fee?

Userlevel 4
Badge +39

Since you have tried with all the possible troubleshooting and the problem is persisting, I suggest you can reach out to for further assistance if the modem is in warranty.

Badge +1

I've already returned the modem to Amazon. Turns out, even if it worked, the Arris S33 doesn't support the 240 upload speed that is part of my comcast plan.