Frustrating experience with SURFboard SGB7600AC2

  • 20 February 2023
  • 0 replies


I tried replacing my rental modem/router/wifi with a SGB7600AC2 and it did not go well.  After informing my cable provider that I wished to use my own modem, they asked me for relevant info about my new modem.  I gave them make/model and MAC info.  My old modem stopped working at which time I plugged in the new one.  I waited 15-20 minutes.  Eventually the default wifi SSID showed up and I connected to it and then connected to the surfboard.  It was at this point that things went sideways.  I could browse some sites on the Internet but not others.  It sort of felt like I was in a walled garden.  However, it finally dawned on me that I was able to reach IPv6 sites (like Facebook) but not sites which only used IPv4 (which happens to be about 75% of the sites that I frequent).  In any case, after looking through the settings and logs, etc, I discovered that the modem was not requesting an IPv4 address via DHCP even though it was configured for DHCP.  I was getting a /60 IPv6 prefix via prefix delegation but no IPv4.  I tried factory resetting the modem (several times).  I tried setting the IPv4 to manual and then back to DHCP (several times).  Nothing worked.  The logging capabilities of the modem are very poor.  There’s very little information that is helpful in diagnosing the issue.  I’m a network engineer by trade and have been doing network troubleshooting for 10+ years and it’s super frustrating that I know exactly what’s wrong with my modem (not getting an IPv4 address on the WAN interface) but I don’t have enough information to know why.  Everybody I talked to (whether ISP support or Arris support) was only focused on the LAN side.  As soon as I mentioned “IPv4 address” they would tell me to go to a command prompt and do an “ipconfig /release”.  I’d just roll my eyes and try to explain, again and again, that this wasn’t my problem but for the most part the support “engineers” wouldn’t go off script.  Of course, since I was trying to use my own modem the provider had no interest in spending much time trying to sort this out. They eventually sent a tech to my house and he couldn’t do anything for me.  I reached out to ARRIS tech support but they weren’t much help.  Realizing that I was pretty much on my own, I returned the surfboard to the retailer and grabbed a Netgear and that worked straightaway.  This seems like a silly problem.  DHCP is a basic network function that has been around for 35+ years.  Everything from my Roku to my dishwasher seems to be able to figure it out but for some reason the surfboard couldn’t get the job done.

This topic has been closed for comments