Unable to login on the Surfboard Central App

  • 19 May 2023
  • 5 replies


Recently bought a SURFboard 5G7600AC2. When I try to activate SURFboard Central on my iPhone SE 2020 and iPad Mini 5 I get error message “Wi-Fi Communication Error” even though I’m connected to the Internet on both devices. Have spoken with two ARRIS technical support agents and neither one could figure out what the problem is. Any help would be greatly appreciated.


Best answer by SURFboard Moderator 21 May 2023, 02:25

View original

5 replies

Userlevel 2
Badge +9

HAve you tried to disable “private address” on both apple devices?

Userlevel 4
Badge +39

Hello artspolice

                     For wifi communication Failure you can try the steps below: 

                          * Restart the Gateway and relaunch the mobile app.  If the issue encounters again, factory reset the gateway and relaunch the mobile app.

                          * Verify the Gateway is powered On and Wi-Fi enable on the mobile device.  Move the mobile device closer to the Gateway.  Disable and re-enable the Wi-Fi connection on the mobile device.  

                       If still same issue persist you can try the surfboard application on android device or you can perform hardest on the modem then reinstall app for setup but, after resetting the modem will go to default setup any custom settings will be removed so use the default network name and password to connect to your network. So to perform reset on the modem you can follow the steps mentioned on the link below


         Let us know if this helps


I was optimistic that turning off Private Address would solve the problem, but it didn’t. Still get “Internet Connection not available” message, although this time with a different error code (0002-1401). Did a reset of the Gateway when I was on the phone with ARRIS, but I’ll try that one more time. Thanks to both of you for your replies.


Just did another reset, this time through the Web Manager. Same result: Wi-Fi Commnication Failure, even though Wi-Fi is working. I give up and will use Fing to monitor my local network. I feel sure there’s some easy fix for the problem with SURFboard Central and find it very surprising that ARRIS customer support can’t help me use an ARRIS app. It’s not surprising that the app has a low rating.


The same happens to me but with arris homeassure app and TG2482 router.